Page 1 of 1

Help - dropped GPS and screen now not working.

Posted: 21 August 08 8:03 pm
by angermanagement
Hi, Out caching today and dropped the GPS on sand. Bugger :evil: :evil:<br> <br> GPS Screen still on but frozen initially. Turned GPS off and on, screen still frozen. Turned off again but when turing back on the screen was not working. <br>GPS making noises like it is on but nothing showing on the screen. I am able to turn back light on but nothing else on screen. <br><br>
A couple of questions. <br><br>
Is it completely broken or is it fixable? A do it at home job or into a repair? Can anyone recommend a repairer in the Brisbane area?
<br><br> Any help would be greatly appreciated.

<br><br>The GPS is a Garmin 60CSX and i don't think it is in warranty still and was brought over ebay from America.

Posted: 21 August 08 9:01 pm
by pjamesk
Have a look here ... enu_Static
theres a few links

Posted: 21 August 08 9:26 pm
by tronador
try removing the batteries, then reinserting and then turn on. Might work, if something is stuck in the on position.

Posted: 22 August 08 7:58 am
by angermanagement
I have tried the batteries and I dusted the sand out of the battery compartment. Took the GPS apart but couldn't see much that was obvious. ANy other suggestions appreciated. Very unhappy with my gps :cry: :cry:

Posted: 22 August 08 9:49 am
by Map Monkey
You could try to access the "GPS system check" screen by holding down the ENTR button whilst turning on. This "may" show something other than the blank screen, which may mean a connection problem or similiar.

A firm tap on the palm of your hand may help if it a connection issue....use at your own risk though. :P

If all else fails, a hard reset (holding down ENTR and PAGE whilst turning on) may be a last check before crying. :shock:


Posted: 22 August 08 10:21 am
by Skippy&lambchops
Will it still work with moving maps via the PC, can you upload and download waypoints and tracks to the unit.

Posted: 22 August 08 1:19 pm
by Wingaap
Reseat the ribbon cable ie the cable which connects the screen to the main board. Be careful with the clip.

Posted: 22 August 08 3:02 pm
by Dooghan
I wonder if it's the SD card just not seated right. Just a thought.

Posted: 22 August 08 6:43 pm
by Dik:
Dooghan wrote:I wonder if it's the SD card just not seated right. Just a thought.
Unfortunately not. I have had the SD card unseated and also fail. The unit works fine, just reverts to the base map.

Posted: 24 August 08 7:46 pm
by angermanagement
I am so very happy. :lol: :lol: No I didn't win the lotto. Wingaap fixed my GPS. Yipee. Yipee. <br><br>Thanks so much for all your suggestions. Most were tried. <br><BR>
But the problem was the ribbon Cable. Which took Wingapp fixed in about 45 minutes of struggling with the plastic pieces to fix. Again thanks to Wingaap for fixing it. Very happy.

Posted: 25 August 08 11:31 am
by Wingaap
Turned out to be a problem similar to that experienced by the eTrex as documented in other places.

The clip holding the ribbon cable for the screen had released easing pressure on said ribbon cable.

An easy enough procedure...just take it easy on the hard plastic fittings.

It was great to see the smile on AM's face :D

Posted: 25 August 08 5:05 pm
by edmil
Well done wingapp.

Will you now be the resident forum GPS fixerupperer :twisted:

I have a gps at home that seems to read maps the wrong way, Continues to beep when the cache has be located by it, Batteries seem to fade after about half a day - surprising works better after being affected by coffee. :lol: What do ya reckon.

Posted: 25 August 08 5:06 pm
by Crisp image
Of course If you had attended those anger management classes you may not have thrown it on to the sand in frustration in the first place!!
Crisp Image